danbooru, memcache and postgresql

Apparently some people got here when googling for “danbooru memcache” – which means I’m not the only one having problem with it.

I posted the solution in there which is pretty simple:

For memcache error (“uninitialized memcache constant”), add this line in config/initializer/002_caching.rb (at line 2):

require 'memcache'

As for postgresql error, comment the line following line in db/migrate20090420182044_revert_enable_auto_complete_on_users.rb (line 3):

remove_column "users", "enable_autocomplete`"

so it looks like this:

#remove_column "users", "enable_autocomplete`"

I don’t know why it’s still unfixed.

Updated installation guide soon, or later. Tell me if you need help for specific Linux distro. Or a variant of *BSD. Installation on OpenSolaris is still painful as ever (and Passenger 2.2.2 doesn’t work on it last time I tried).

Leave a Reply

Your email address will not be published.